百度自动更新SDK的’requiresFadingEdge’错误

使用百度的自动更新sdk,其lib项目,总是报错,如下:
error: No resource identifier found for attribute ‘requiresFadingEdge’ in package ‘android’

我还天真的按他的pdf说明文档来选择的android 2.2,其实问题就在这儿,需要选择android 4以上。我选择是4.1.2。就有requiresFadingEdge了。


要说,百度,这几天到处报道说百度的android应用里都有危险漏洞,会被别有用心的利用,给用户手机装上危险的东西。

百度市场却强制要求开发者必须用百度的自动更新sdk或appx广告。

然后,他们的sdk却作得这么烂。连文档也写出问题,给的zip包里面也有重复的目录。
严重怀疑,这一块是外包出去的,而且工资太低了或是找的后门进的员工。严重打晃啊。